Updates

Minecraft 1.4.7 Pre-release

by Jens Bergensten on December 28, 2012

Unfortunately we managed to include two “null pointer exception” cases in 1.4.6, and we feel they should be patched.

This release is compatible with 1.4.6 and has almost no bytecode changes, so mods that have been updated for 1.4.6 should work in 1.4.7 too. The only affected file is the one called “qz”, which is the arrow projectile’s class. This also means that 1.4.6 clients can play on 1.4.7 servers, and 1.4.7 clients on 1.4.6 servers… so we’ll wait until after New Year’s Eve before we publish it in the launcher. Download the pre-release if you want these problems fixed before then!

The fixes are:

  • Fixed crash related to arrows fired from dispensers
  • Fixed a multiplayer crash when using fireworks without a fireworks star
  • Fixed long timeout when checking SRV records

Get the pre-release here:

Report bugs here:

Happy New Year!

// The Minecraft Team

Comments on this entry are closed.

Previous post:

Next post:

© 2010-2014 Mojang AB